Free shipping to the United States when you order $20+

Hands on review and a few pics
Login to post a new topic and to write a reply.
Thread Tools


Search within thread:

Rate This Thread
Login to rate this thread.
#11 (permalink)      4/2/2018 8:36:38 AM US Central   quote/reply + tips
Avatar
djvillan
Verified
XDM45ACP wrote:

SORRY, DJ! BUT I CALL BULLSHIT!... First thing I received mine, and the fake chain link decal was peeling off. But let's talk about the two-minute hack, I'm very mechanically inclined, have the tools and the mind to do the job, the only thing I was missing was my Step drill bit yesterday, (my Son, so kindly forgot to return) but I still put my Mod Maker 510 on temp. So I tore down the $20 mod and went to town! removed the battery sled did some grinding on the contacts with my Dremel tool, come to find out that the contacts are not plated copper, just some cheap Chinese metal. Anyway put it all back together, and found out that the only Batteries that will fit is the18650 no 2x700, no way no how! unless you cut out the front panel or the back panel the 20700 just barely fits with a little front panel rocking action, but not acceptable. and the only way for the 2x700 to fit is this... JUST GIVING YOU BUSINESS DJ!! lol.


Both of mine fit 20700's and had silver plated copper contact plates. They weren't obtained from here. Maybe the front plate and back on yours are thicker than mine and you got a revised batch. Sold my black and blue ones three weeks after I posted my initial review.

leftjeffa wrote:

Lol. At least you're honest


I reviewed what I got.

#12 (permalink)      4/2/2018 9:54:18 AM US Central   quote/reply + tips
Avatar
leftjeffa
Verified
  • JoinedAug 2013
  • Posts 6322
  • Reviews 39
  • Kudos9256
+2 details
Pics or it didn't happen...oh, you sold them. Heheh
Resistance is not futile, it's V/I
#13 (permalink)      1/24/2022 12:43:37 AM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8
+1 details
I figured I'd give this dinosaur a try (hoping for a better experience than I had with the Coil Father). Well I'm having trouble getting reliable 510 connectivity with 3 different RDA's. It seemed OK for first few hours. Maybe I was using tons of force thinking problem was the contact (which I deformed a bit and is now too sensitive, LOL.. anyway, easy to tune later) and sort of deformed various parts and so enabled intermittent contact allowing some vape action.

I pressed the 510 down with a screwdriver a bunch of times to observe it spring back nicely, wishfully hoping it would find a new higher neutral position.

I suppose I'll eventually unscrew the upper threaded washer all the way out (I can rotate it little by little) to see what I can do. If anyone knows a way to adjust the 510 hot center height (with or without removing washer) to get reliable operation, I'd love to hear it. (And how does one fully re-tighten washer? special tool?)

I'm also confused about the brass contact disc: when I rotate it all the way to uppermost position, it just spins. What's the point of that? It can't be good for electrical conduction. At times it did become very hot but I don't think that's my main problem.

Another weird thing: I tend to overdrip, and this is the first squonker where liquid collects in the bottle in noticeable amounts. I guess tube inner diameter is larger.
#14 (permalink)      1/30/2022 12:50:08 AM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8

Edited on 1/30/2022 at 12:51 AM. Reason: last post got blown away, captcha fail
#15 (permalink)      1/30/2022 12:59:01 AM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8
+2 details
NeilWpgFT wrote:

I suppose I'll eventually unscrew the upper threaded washer all the way out ..

I went through about 15 cycles of removing & reinstalling the 510 pin in order to raise it.

Tried:

tuning the spring.

placing an insulating washer under the pin (nice diam but a bit tall).

sliced that washer into two shorter ones, and tried those.

spring + modified washer.

I never achieved reliable firing. (Exception: on one RDA if I unscrew squonk pin 1-2 turns I do get some action but I don't like running RDA like that)

I'm pretty sure I stripped the black (ABS? ultron? sorry, I'm not a materials guy) insulating disc that threads on to the upper conducting (batt negative) disc, even though I mostly used finger force when lamely trying to tighten things. During some of my attempts, when pushing the pin down into the assembly, the black disk would pop off the upper metal disc. And I say I stripped it because when I tighten the black disc now there's a click and it keeps turning. I tried bits of tape on its inner thread to firm things up but I don't think it helped much.

And as before, when I tighten the lower (brass?) conducting disc (that "L" strip contacts) it just doesn't feel like a proper mechanical tightening.

So looks like I made it worse: previously I at least had unreliable intermittent vape action.

Then I cut strip of SS ribbon, bent it into a U with one longer end and seated it in the squonk pin; mod nows work, prob as a non-squonker or maybe a constricted one. And maybe it hits softer than it should, not sure yet. I might also ask FT to replace it or provide credit for it (even though I altered it in the hope of saving both them and me time and trouble).


Edited on 1/30/2022 at 12:59 AM. Reason: formatting
#16 (permalink)      1/30/2022 4:40:19 AM US Central   quote/reply + tips
Avatar
djvillan
Verified
+1 details
I no longer have mine but to fix your issues you need to replace the 510 pin and assembly. SKU 9620836

Edited on 1/30/2022 at 4:41 AM. Reason:
#17 (permalink)      1/30/2022 1:21:18 PM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8
djvillan wrote:

I no longer have mine but to fix your issues you need to replace the 510 pin and assembly. SKU 9620836


Thanks, good to know that's a possibility. (That hex nut, something that can be properly tightened, that's so 21st century!). Annoying that a brand new product should need this, though.

#18 (permalink)      1/30/2022 2:44:09 PM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8
(Bringing over comment from other place)

carrion4worm wrote:

Are you sure your battery is making contact?

Sounds like your 510 is spring loaded and works fine in that regard, per your description. I find it odd that not 1, but all your atties have short 510 connections...if you watch the inner 510 while screwing on an atty, you will see the 510 tube lower as the atty makes contact and the spring does its' job.

Try it! If you see the movement, then you know for certain that the atty is making contact.

You may need to pry gently on the neg or pos battery connect, or you could have over-wrapped batteries and the wrap is blocking connection.

Try these for starters, let us know how it goes.

#19 (permalink)      1/30/2022 2:45:35 PM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8
(Bringing over comment from other place)

cilika wrote:

I could save some wobbly and leaking connectors by taking apart and shoving an o-ring under the insulator in the (far) past, but would trust manually adjustable pins much more.

My very first reg. squonker (an Aleader box) had the same problem, it worked just fine for 2 weeks with the same RDA, the moment I changed the atty on it for an other which had probably a longer pin, i felt a slight "crack" and from that point, most of my attys didn't want to make contact with it any-more. I just simply desisted with reg. squonkers for the future. (as i could never put my mind for soldering... de-soldering for to take it apart)

If you can make a break down and some photos about your connector, maybe it'd be a help (for to help)

#20 (permalink)      1/30/2022 2:46:58 PM US Central   quote/reply + tips
NeilWpgFT
Verified
  • JoinedSep 2015
  • Posts 55
  • Reviews 13
  • Kudos8
(Bringing over comment from other place)

cilika wrote:

I guess that phenomenon happens when the little spring's leg on one side gets stuck in something.