[dismiss] Holiday closure: from January 27th to February 7th, 2022. Shipping and support will resume on February 8th, 2022. (details)
FastTech wishes you and yours a safe and prosperous year of Tiger 🐱.
Free shipping to the United States when you order $20+

Can't get it to work
Login to post a new topic and to write a reply.
Thread Tools


Search within thread:

Rate This Thread
Login to rate this thread.
#1 (permalink)      11/7/2020 4:34:53 AM US Central   quote/reply + tips
raineysky
Member
  • JoinedApr 2017
  • Posts 69
  • Reviews 0
  • Kudos21
Can't get it to work
After I put a coil in and wick it everything is fine on a Pico regulated mod. Resistance is spot on at 1.2 ohms, no shorts. Fires beautifully. When I put the Exocet V2 in the SXK Billet Box or Bantam Box the resistance will read 0.03 - 0.05. Any ideas on what is going on? The BB nut screws on flush just like my other bridges.

EDIT: I've tried all three air inserts

Edited on 11/7/2020 at 4:36 AM. Reason:
#2 (permalink)      11/7/2020 4:57:46 AM US Central   quote/reply + tips
Avatar
analogueman
Member
  • JoinedAug 2013
  • Posts 2489
  • Reviews 4
  • Kudos1981
Sounds like it's shorting somewhere. That's usually the case when the ohms plummet like that.
It's twelve inches long, but don't use it as a rule...
#3 (permalink)      11/7/2020 6:20:13 AM US Central   quote/reply + tips
Lalli
Member
  • JoinedSep 2016
  • Posts 214
  • Reviews 2
  • Kudos149
Coil is touching the chimney? Try to fire it with chimney on in your pico.
#4 (permalink)      11/7/2020 9:05:18 AM US Central   quote/reply + tips
Avatar
Dustin69
Member
  • JoinedMay 2019
  • Posts 111
  • Reviews 32
  • Kudos76
One of your leads is too long and touching the barrel.
#5 (permalink)      11/7/2020 8:10:16 PM US Central   quote/reply + tips
raineysky
Member
  • JoinedApr 2017
  • Posts 69
  • Reviews 0
  • Kudos21
+1 details
Thanks for the responses. I have tried several coils now and none will work. The coil is not touching the chimney or the barrel. I wiggle the wire to break it flush and the coil is not above the post. Reads and fires perfect on the Pico with or without the cap on. Leads me to believe something is going on with the air inserts not making good contact.

UPDATE: I bent the ends on one of the air inserts a little with pliers so it would sit better on the contact. That Worked!!! Not ready to do the happy dance just yet though. It's working in the Bantam Box but I haven't tried the SXK Billet Box yet....

I've been having hell with air inserts lately :-) Same thing happened with a Spica Pro not long ago. Got new air inserts and the damn thing started working.
#6 (permalink)      4/1/2021 10:33:59 PM US Central   quote/reply + tips
deb22
Member
  • JoinedOct 2015
  • Posts 121
  • Reviews 16
  • Kudos32
Mine says shorted every coil I put in.
Waited for a month for this order and still can't use mine..
#7 (permalink)      4/20/2021 6:51:48 PM US Central   quote/reply + tips
Kamikaze702k
Member
  • JoinedDec 2016
  • Posts 531
  • Reviews 4
  • Kudos217
+1 details
I noticed on this, this happened to me. If you put the top cap onto the deck one way, it will short, the other way it won't, this is due to the design of the deck post if you look one of them it's slightly tilted, just try the top cap the opposite side and no more shorts