[dismiss] FastTech will be on holiday from October 1, 2022 to October 7, 2022. All services resume on October 8, 2022, at 1:00 am (UTC). (details).
Free shipping to the United States when you order $20+

Anyone elses DNA60 feel lazy in this one?
Login to post a new topic and to write a reply.
Thread Tools


Search within thread:

Rate This Thread
Login to rate this thread.
#1 (permalink)      8/5/2022 7:23:12 AM US Central   quote/reply + tips
njrmayo
Verified
  • JoinedSep 2020
  • Posts 472
  • Reviews 1
  • Kudos133
Anyone elses DNA60 feel lazy in this one?
Hey all,

Just curious for the DNA60 peeps that got this, does your chipset feel lazy or slouchy? After 80% battery life I can't get the wattage I'm requesting, regardless of battery. I only run Molicel P26A's and P28A's and this batch of batteries is all under 6 months old, properly charged, blah blah blah blah its not the batteries, they're solid in all my other DNA60 and 250C mods, etc. But in this thing I'm lucky to get 30w after 70-80% battery life remaining. Escribe looks correct, settings all correct and everything. Is there a way to force this DNA60 to be better? hahaha.

Thanks in advance!
#2 (permalink)      8/5/2022 9:20:58 AM US Central   quote/reply + tips
Avatar
Technomania
Verified
  • JoinedSep 2013
  • Posts 219
  • Reviews 1
  • Kudos192
Mine's been practically glued to my hand since it's arrival, and functions just as well as any of the other DNA 60's I have. Full set wattage available until the battery is depleted.
"We've taken care of everything, The words you read, The songs you sing, The pictures that give pleasure to your eyes"....(Priests of Syrinx, 2112 AD)
#3 (permalink)      8/5/2022 11:01:00 AM US Central   quote/reply + tips
njrmayo
Verified
  • JoinedSep 2020
  • Posts 472
  • Reviews 1
  • Kudos133
Technomania wrote:

Mine's been practically glued to my hand since it's arrival, and functions just as well as any of the other DNA 60's I have. Full set wattage available until the battery is depleted.



As it should, for sure, especially with a DNA chip.. Hrmmm I wonder what's up with this one.

#4 (permalink)      8/5/2022 3:06:36 PM US Central   quote/reply + tips
inswva
Verified
  • JoinedSep 2014
  • Posts 168
  • Reviews 1
  • Kudos244
Shitty soldering?
#5 (permalink)      8/6/2022 11:36:13 AM US Central   quote/reply + tips
njrmayo
Verified
  • JoinedSep 2020
  • Posts 472
  • Reviews 1
  • Kudos133
inswva wrote:

Shitty soldering?



That's what I'm thinking.. It already arrived with the DOA screen so I wouldn't be shocked if the soldering or chip was janky as well...

#6 (permalink)      8/6/2022 7:49:38 PM US Central   quote/reply + tips
Avatar
dwcraig1
Verified
  • JoinedJun 2013
  • Posts 397
  • Reviews 7
  • Kudos247
+1 details
Use EScribe while firing and note voltage drop. If it drops to 2.75 volts or lower it will throttle down. While the cell might be up to the task the battery's connection to the board may not be ideal. Start by cleaning battery connections with q-tip and alcohol. Does the battery appear to fit tight enough?
#7 (permalink)      8/7/2022 12:35:19 AM US Central   quote/reply + tips
njrmayo
Verified
  • JoinedSep 2020
  • Posts 472
  • Reviews 1
  • Kudos133
dwcraig1 wrote:

Use EScribe while firing and note voltage drop. If it drops to 2.75 volts or lower it will throttle down. While the cell might be up to the task the battery's connection to the board may not be ideal. Start by cleaning battery connections with q-tip and alcohol. Does the battery appear to fit tight enough?



Yeah it seems to fit nicely, both my P26A's and P28A's are a good fit but not overly snug, the spring loaded positive connection works fine and the cap is tight fitting, especially with the nut tightened down. I checked on escribe but not on a full battery, I'll check both again with a 50% battery and a 100% battery and see what it's showing for drop while firing. Thanks for the info.

#8 (permalink)      8/14/2022 9:18:37 AM US Central   quote/reply + tips
Ericsgreen
Verified
  • JoinedJan 2020
  • Posts 116
  • Reviews 20
  • Kudos32
Omfg, thank you! I been out a bit, my support ticket isn't getting much reply either, mine has been total shit, bad female threads but this definitely isn't up to snuff for a DNA, I emailed evolv but haven't heard back yet, for those who want to dislike their new ion, take ankther DNA boro, use the same tank, bridge and Drip tip and watch how much this sags, it won't boost if you use int firmware, battery flashes way earlier and dies way earlier, we got somethung junky going on here
#9 (permalink)      8/14/2022 9:20:14 AM US Central   quote/reply + tips
Ericsgreen
Verified
  • JoinedJan 2020
  • Posts 116
  • Reviews 20
  • Kudos32
That was supposed to say same tank, battery and Drip tip, run it in the other DNA boro then the ion, there's no question... I think low wattage users, maybe tc, and mtl folk aren't gonna have much trouble, God help you if you run a half ohm and vape over 40w or use boost though
#10 (permalink)      8/15/2022 6:29:38 AM US Central   quote/reply + tips
njrmayo
Verified
  • JoinedSep 2020
  • Posts 472
  • Reviews 1
  • Kudos133
Ericsgreen wrote:

That was supposed to say same tank, battery and Drip tip, run it in the other DNA boro then the ion, there's no question... I think low wattage users, maybe tc, and mtl folk aren't gonna have much trouble, God help you if you run a half ohm and vape over 40w or use boost though



Yeah dude exactly! I'm not sure what's going on with this thing. on 77% battery, Molicel P26A from 5/22/22, 42w, 0.25ohm build, my standard aliens in my boro's. it won't hit 36 watts.. Escribe all looks fine, everythings up to snuff. I'm getting quite annoyed.

#11 (permalink)      8/15/2022 9:23:30 AM US Central   quote/reply + tips
Avatar
dwcraig1
Verified
  • JoinedJun 2013
  • Posts 397
  • Reviews 7
  • Kudos247

Here is one of my SXK DNA60 Billet Boxes firing a .210 ohm coil at 45 watts. Note the voltage drop is 3.65 volts at it's lowest.
Upon looking at a video of the non styled ION Box I would really be wondering just how that battery door is going to make a good connection to the board, I'm pretty sure the problem will be found there.

Edited on 8/15/2022 at 9:29 AM (addition)